System Delays

Incident Report for Boulevard

Resolved

This incident has been resolved and all systems should now be operating as normal. We apologize for any inconvenience that has been caused.
Posted Jul 29, 2025 - 09:51 PDT

Monitoring

We have identified the issue and put a solution into place. We are continuing to monitor.
Posted Jul 29, 2025 - 08:56 PDT

Investigating

We are currently aware of an issue causing users to experience system delays. We are actively investigating this and will post an update once we have more information.
Posted Jul 29, 2025 - 08:09 PDT
This incident affected: Dashboard and Professional App.