Data Processing Delays - Membership Renewals

Incident Report for Boulevard

Resolved

This incident has been resolved and all membership renewals have processed. We apologize for any inconvenience that has been caused.
Posted Aug 01, 2025 - 16:02 PDT

Update

All membership renewals have been processed for customers. Our team is continuing to monitor the membership renewals that took place today.
Posted Aug 01, 2025 - 14:46 PDT

Monitoring

Most membership renewals have now processed for customers. Our team is actively monitoring to make sure all customers have finished processing membership renewals.
Posted Aug 01, 2025 - 11:29 PDT

Identified

The issue has been identified and our team is working on a potential fix for the issue.
Posted Aug 01, 2025 - 10:17 PDT

Investigating

We are currently investigating an issue with delayed Membership Renewals. We will provide an update as soon as possible.
Posted Aug 01, 2025 - 08:17 PDT
This incident affected: Dashboard.