Issues with viewing forms

Incident Report for Boulevard

Resolved

The issue has been identified and resolved. Forms can now be viewed properly by staff members with the appropriate permissions. Please reach out to the Help Chat if you are still experiencing issues.
Posted Aug 26, 2025 - 17:23 PDT

Investigating

We are aware of an issue that is preventing some staff from viewing forms attached to appointments. We are currently investigating and will provide an update shortly. We apologize for any inconvenience this may cause.
Posted Aug 26, 2025 - 16:56 PDT
This incident affected: Dashboard.