Subscription Processing Error
Incident Report for Boulevard
Resolved
This incident has been resolved.
Posted Feb 04, 2025 - 10:06 PST
Identified
Due to a system error, some subscription payments were mistakenly marked as declined, but no charges were actually made. No action is needed from customers at this time. We will continue to update shortly.
Posted Feb 04, 2025 - 07:15 PST
This incident affected: Dashboard.