Offset Outage

Incident Report for Boulevard

Resolved

The third party provider has resolved their issue and Offset should now be functioning properly for all transactions. We apologize for any inconvenience.
Posted Jul 11, 2025 - 10:53 PDT

Identified

We are currently unable to verify Offset eligibility for some cards due to a third party provider outage. Some cards may not have Offset applied, even if eligible. We are currently awaiting an update from the third party and will provide further updates as soon as they are available.
Posted Jul 11, 2025 - 10:36 PDT
This incident affected: Dashboard and Duo App.