Reporting Disruption

Incident Report for Boulevard

Monitoring

Our infrastructure partner has implemented a fix and we have confirmed reports are successfully loading. We will continue to monitor. Please reach out to the Help Chat if you are still experiencing issues.
Posted Aug 26, 2026 - 19:27 PDT

Update

We are continuing to investigate the issue with our infrastructure partner and will provide another update soon. We apologize for this disruption.
Posted Aug 26, 2026 - 18:50 PDT

Investigating

We're currently experiencing an issue with our infrastructure partner that is affecting the ability to load Reports. We're actively investigating and will share another update soon.
Posted Aug 26, 2026 - 17:34 PDT
This incident affects: Dashboard.