An issue with a third-party service with some emails being marked as spam

Incident Report for Boulevard

Resolved

The third-party service confirmed that the issue has been resolved.
Posted Mar 24, 2025 - 20:21 PDT

Monitoring

The third-party service confirmed that a fix had been deployed to address Gmail recipient emails being sent to spam. They are actively monitoring the progress, and additional updates will be provided once they fully resolve the issue.
Posted Mar 24, 2025 - 16:30 PDT

Investigating

We are currently experiencing a service interruption due to an issue with a third-party service with some emails being marked as spam for Gmail users. They are currently working with Google to resolve them. We apologize for any disruption and will provide an update soon.
Posted Mar 24, 2025 - 15:09 PDT
This incident affected: Dashboard, Professional App, and Client Portal.