Offset Fee Error

Incident Report for Boulevard

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 07:53 PDT

Investigating

We’re investigating an issue where some clients may not be charged an Offset fee. We sincerely apologize for any inconvenience this may cause.
Posted Mar 24, 2025 - 06:36 PDT