Unable to checkout or add payment for online booking

Incident Report for Boulevard

Resolved

This incident has been resolved.
Posted Mar 01, 2026 - 12:05 PST

Update

All customers can now be able to checkout clients without issue.
Posted Mar 01, 2026 - 11:24 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2026 - 11:20 PST

Update

We are currently investigating an intermittent issue impacting checkout attempts for some customers.

Two workarounds are currently available:
1. Checkout with card on file
2. Re-enter credit card information and retry
Posted Mar 01, 2026 - 10:50 PST

Update

Hello, we are currently investigating the issue.

In the meantime, please use the card on file as a payment method. Alternatively, you can try re-entering your credit card information, as the errors are intermittent and are not affecting all payments and bookings.
Posted Mar 01, 2026 - 10:40 PST

Investigating

We are aware of an issue where some customers are not able to checkout clients. We are actively investigating this issue and will provide another update soon.
Posted Mar 01, 2026 - 10:30 PST
This incident affected: Dashboard.