Beta Report Interruption
Incident Report for Boulevard
Resolved
This issue has been resolved. We apologize for any inconvenience.
Posted Oct 05, 2023 - 11:26 PDT
Monitoring
At this time, all reports look to be responding within normal parameters. We are monitoring before declaring this issue fully resolved.
Posted Oct 04, 2023 - 13:21 PDT
Update
We have identified an issue where some customers are seeing slowness or timeouts from certain reports. Currently it appears Beta Reports and Sales Reports in-app are affected. We are currently investigating and will provide an update as soon as possible.

If you are experiencing this issue please wait a few minutes before re-attempting any reports.
Posted Oct 04, 2023 - 12:03 PDT
Investigating
We have identified an issue where some customers are seeing slowness or timeouts from certain reports. Currently it appears Beta Reports and Sales Reports in-app are affected. We are currently investigating and will provide an update as soon as possible.
Posted Oct 04, 2023 - 11:55 PDT
This incident affected: Dashboard and Professional App.