Professional App Disruptions
Incident Report for Boulevard
Resolved
The issues with logging into the Professional App and Duo App have been resolved. Please reach out to the Help Chat if you are still experiencing issues.
Posted Nov 15, 2024 - 05:48 PST
Monitoring
The login issues with the Professional App and Duo App have been identified and a fix has been implemented. Users are able to login. We are continuing to monitor the situation and will provide another update soon.
Posted Nov 15, 2024 - 05:43 PST
Update
We are aware of the issue of some customers not being able to login into the Duo app. We are continuing to investigate this issue in addition to the Professional App.
Posted Nov 15, 2024 - 05:07 PST
Investigating
We are aware of the issue causing some users not to be able to login into the Professional App and are currently investigating.
Posted Nov 15, 2024 - 05:04 PST
This incident affected: Professional App.