Degradation in webhook and notification performance

Incident Report for Boulevard

Resolved

The issue has been resolved and is operating as normal. Please reach out to the Help Chat if you continue to experience issues.
Posted Nov 15, 2025 - 10:44 PST

Monitoring

We have implemented a fix to help solve these delays. Even after this fix, you may experience some minor delays while we continue to monitor the issue.
Posted Nov 15, 2025 - 10:23 PST

Investigating

We are actively investigating degradation in webhook and notification performance, and will provide an update soon.
Posted Nov 15, 2025 - 08:56 PST
This incident affected: Dashboard and Professional App.