Appointment Creation Issue in Professional App

Incident Report for Boulevard

Resolved

This has been resolved. Please reach out via Help Chat or support@blvd.co if you are still experiencing issues.
Posted Jun 25, 2025 - 15:01 PDT

Investigating

We are aware that some customers are having issues creating appointments in the Professional App. We are currently investigating this matter and will provide another update shortly.
Posted Jun 25, 2025 - 11:13 PDT
This incident affected: Professional App.