Third-party service for help chat isn't loading

Incident Report for Boulevard

Resolved

The service outage from a third-party service has been resolved, and we are now operating normally. We apologize for any inconvenience.
Posted Apr 24, 2025 - 13:20 PDT

Investigating

We are currently experiencing a service interruption due to an issue with a third-party service. Due to this issue our support functions including chat, email, and automated support are unavailable. We have contacted them and will provide an update as soon as possible.
Posted Apr 24, 2025 - 13:13 PDT