Login issues

Incident Report for Boulevard

Resolved

The login issue affecting some customers has been resolved. All customers should now be able to login successfully.
Posted Sep 16, 2026 - 16:24 PDT

Update

We are continuing to monitor the login issue affecting some customers. We are seeing improvements and most customers should no longer be impacted.
Posted Sep 16, 2026 - 14:57 PDT

Monitoring

We’ve identified the issue affecting some users when logging in and have implemented a fix. We’re currently monitoring the results as access continues to be restored.
Posted Sep 16, 2026 - 12:23 PDT

Investigating

We are currently investigating a login issue affecting some customers. We will will provide an update as soon as possible.
Posted Sep 16, 2026 - 11:17 PDT