Delay with staff notifications

Incident Report for Boulevard

Resolved

This issue has been resolved. We sincerely apologize for any disruptions this may have caused.
Posted Oct 01, 2025 - 16:30 PDT

Monitoring

Our team has identified the source of the issue and have implemented a fix. We will continue to monitor the results and will provide an update if anything further changes.
Posted Sep 30, 2025 - 18:38 PDT

Investigating

We are aware of an issue where some customers are experiencing delays with staff members not receiving notifications. We are actively investigating this issue and will provide another update soon.
Posted Sep 30, 2025 - 17:03 PDT
This incident affected: Dashboard and Professional App.