Payment Processing Interruption
Incident Report for Boulevard
Resolved
All payment processing issues should now be resolved. We apologize for any inconvenience.
Posted Mar 27, 2024 - 11:12 PDT
Monitoring
Our banking partner has indicated they have resolved all processing and connectivity issues on their platform. We are currently monitoring to make sure the issue is fully resolved. Please feel free to re-attempt any failed transactions .
Posted Mar 27, 2024 - 10:19 PDT
Identified
Our banking partner has identified an issue in their platform and are currently working to resolve it. Some transactions may fail during this period. Please re-attempt any failed transactions.
Posted Mar 27, 2024 - 10:11 PDT
Investigating
We are experiencing an issue with our banking partner and are currently investigating. During this time you may receive an error when processing a transaction for some customers. We will provide further updates as soon as possible.
Posted Mar 27, 2024 - 09:46 PDT
This incident affected: Dashboard.