Dispute Outage

Incident Report for Boulevard

Identified

Our banking partner is currently experiencing a technical issue with their dispute handling capabilities. They have identified the issue and are currently working to resolve it. During this time you may receive an error when attempting to submit a dispute. We are tracking this issue and will provide updates as they become available.
Posted May 06, 2025 - 05:39 PDT

Investigating

Our banking partner is currently experiencing a technical issue with their dispute handling capabilities. They are currently investigating. During this time you may receive an error when attempting to submit a dispute. We are tracking this issue and will provide updates as they become available.
Posted May 05, 2025 - 10:09 PDT