Scheduled Maintenance

Scheduled for Jan 19, 00:00 - 02:00 PST

Update

We will be undergoing scheduled maintenance during this time.
Posted Jan 16, 2026 - 11:50 PST

Scheduled

Boulevard will be performing scheduled maintenance on Monday January 19 between 3:00 AM EST to 5:00 AM EST. Customers can expect a brief interruption up to 15 minutes during this time.

During the remainder of the maintenance window, services will continue to be available, however some users may experience brief periods of slower performance while maintenance is performed.
Posted Jan 16, 2026 - 11:49 PST
This scheduled maintenance affects: Dashboard, Duo App, Professional App, Self-Booking Overlay, and Client Portal.