Payment Processing Disruption
Incident Report for Boulevard
Resolved
This incident has been resolved.
Posted Jan 24, 2025 - 13:21 PST
Update
We have identified the issue and put a solution into place. We are continuing to monitor. Customers can attempt to re-run transactions.
Posted Jan 23, 2025 - 13:51 PST
Monitoring
We have identified the issue and are working on a solution.
Posted Jan 23, 2025 - 13:51 PST
Update
We are continuing to investigate this issue.
Posted Jan 23, 2025 - 13:19 PST
Investigating
Some customers are currently experiencing issues with payment processing and closing orders. We are currently investigating and will provide an update shortly. We apologize for any interruptions this may cause.
Posted Jan 23, 2025 - 12:15 PST
This incident affected: Dashboard.