Issue Submitting Drafted Forms
Incident Report for Boulevard
Resolved
This issue has been resolved and customers should be able to resume submitting forms without issue. We will continue monitoring.
Posted Nov 16, 2023 - 16:01 PST
Identified
We have identified that the issue is limited only to drafted forms and are currently deploying a fix to address this. We will update once we have additional information.
Posted Nov 16, 2023 - 15:07 PST
Investigating
We are currently aware of an issue leading to the inability to submit some forms. We are actively looking into this issue and will update as soon as we have additional information.
Posted Nov 16, 2023 - 14:42 PST
This incident affected: Dashboard.