Beta Reports Delayed
Incident Report for Boulevard
Resolved
The Beta Report should now be back up and running! Please reach out to the Help Chat if you are still experiencing issues. We sincerely apologize for any disruptions this caused you and our team is continuing to work on improving the dashboard to prevent issues like this in the future.
Posted Sep 14, 2023 - 14:47 PDT
Monitoring
We have implemented a fix to the Beta Report to help solve this issue. Even after this fix, you may experience some delays while we continue to monitor the Beta Report.
Posted Sep 14, 2023 - 11:54 PDT
Investigating
We are aware of an issue where some customers are not able to access the Beta Reports. We are actively investigating this issue and will provide another update within the next hour.
Posted Sep 14, 2023 - 11:32 PDT
This incident affected: Dashboard.