Delayed Reporting

Incident Report for Boulevard

Resolved

The issue with the third party has been resolved and all reporting data should now be caught up and displaying as normal. We apologize for any inconvenience this has caused you.
Posted Jan 15, 2026 - 14:09 PST

Investigating

We’re investigating an issue with a third-party vendor that is preventing reports, marketing data, and Professional App reporting from updating correctly. We’re actively working with the vendor and will provide an update soon.
Posted Jan 15, 2026 - 13:23 PST
This incident affected: Dashboard and Professional App.