Service Interruption
Incident Report for Boulevard
Resolved
The Boulevard Platform is fully operational and the engineering team will be monitoring to ensure continued operation.
Posted Nov 29, 2023 - 10:11 PST
Identified
An issue has been identified and a fix is being implemented. Users may experience issues with the ReachAI integration.
Posted Nov 29, 2023 - 09:44 PST
Investigating
We are currently experiencing a service interruption and are investigating. We will provide an update as soon as possible.
Posted Nov 29, 2023 - 09:17 PST
This incident affected: Dashboard, Duo App, and Professional App.