Dashboard and mobile app delay
Incident Report for Boulevard
Resolved
The dashboard and mobile app should now be back up and running normally! Please reach out to the Help Chat if you are still experiencing issues. We sincerely apologize for any disruptions this caused you, and our team is continuing to work on improving the dashboard to prevent issues like this in the future.
Posted Sep 19, 2023 - 10:03 PDT
Monitoring
We have implemented a fix to help solve these delays. We will continue to monitor the dashboard and mobile app.
Posted Sep 19, 2023 - 09:28 PDT
Investigating
We are aware of some delays with the dashboard and mobile app that may be affecting some customers, and are actively investigating this issue and will provide another update within the next hour.
Posted Sep 19, 2023 - 09:22 PDT
This incident affected: Dashboard and Professional App.