Classic reports are temporarily down
Incident Report for Boulevard
Resolved
Classic Reports have been restored. If you’re still experiencing any issues, please let us know. We apologize for the disruption.
Posted Apr 07, 2024 - 21:01 PDT
Investigating
Some customers have reported issues with Classic Reports. We are investigating.
Posted Apr 07, 2024 - 20:23 PDT
This incident affected: Dashboard.