Unable to access the dashboard
Incident Report for Boulevard
Resolved
The dashboard should now be back up and running! Please reach out to the Help Chat if you are still experiencing issues. We sincerely apologize for any disruptions this caused you and our team is continuing to work on improving the dashboard to prevent issues like this in the future.
Posted Jan 17, 2024 - 08:07 PST
Identified
We have identified the issue and are currently deploying a solution. You can follow any updates at https://status.joinblvd.com/
Posted Jan 17, 2024 - 08:01 PST
Investigating
We are aware that the dashboard is currently down. We are actively investigating this issue and will provide another update soon.
Posted Jan 17, 2024 - 07:53 PST
This incident affected: Dashboard, Duo App, and Professional App.