Reporting and Dashboard Performance Issues

Incident Report for Boulevard

Resolved

The issue affecting reporting and dashboard performance has been resolved, and services are now operating normally.

We apologize for any inconvenience.
Posted May 07, 2026 - 20:47 PDT

Monitoring

We have taken steps to mitigate the issue affecting reporting and dashboard performance, and customers should begin seeing improved load times.

Our team is continuing to monitor performance closely and will provide another update once we confirm the issue is fully resolved.
Posted May 07, 2026 - 20:23 PDT

Investigating

We are aware that some customers are experiencing reporting and dashboard slowness or failures to load. This is due to an issue currently affecting Amazon Web Services. We are actively monitoring the situation and working to restore normal performance. We will provide further updates as soon as possible.
Posted May 07, 2026 - 20:20 PDT
This incident affected: Dashboard.