Intermittent Issues with the Duo

Incident Report for Boulevard

Resolved

The duo should now be back up and running! Please reach out to the Help Chat if you are still experiencing issues.
Posted Nov 25, 2025 - 14:48 PST

Investigating

We are aware that some customers are experiencing issues with payment processing at checkout with the duo. We are actively investigating this issue and will provide another update within the next hour.
Posted Nov 25, 2025 - 12:40 PST
This incident affected: Dashboard and Duo App.