Connectivity issues for select CA customers
Incident Report for Boulevard
Resolved
All of the customers who reported connectivity issues have regained access.
Posted Mar 05, 2024 - 14:01 PST
Update
Most customers who previously reported issues have regained access to Boulevard. We are continuing to monitor.
Posted Mar 05, 2024 - 13:34 PST
Monitoring
We have received reports that some California customers are experiencing difficulties accessing the Boulevard Dashboard and Mobile App. This appears to be tied to use of a specific internet service provider (ISP).

Customers with an alternate connection method, like a hotspot or cellular data, have been able to connect to Boulevard.

We are monitoring the issue and will provide another update within an hour.
Posted Mar 05, 2024 - 13:17 PST
This incident affected: Dashboard and Professional App.