Duo Update Issue
Incident Report for Boulevard
Resolved
This issue is now resolved. We apologize for any inconvenience.
Posted Dec 15, 2023 - 10:04 PST
Investigating
We are currently investigating an issue affecting a limited group of customers that occurs when updating the Duo Firmware. At this time, please do not update your Duo firmware if prompted. We will provide another update when this has been resolved.
Posted Dec 14, 2023 - 07:46 PST
This incident affected: Dashboard.