Offers Not Appearing

Incident Report for Boulevard

Resolved

A fix has been deployed and Offers should now be displaying appropriately for all users. We apologize for any inconvenience.
Posted Jul 14, 2025 - 13:45 PDT

Investigating

We are currently investigating an issue where some users are unable to see the Offers section during Checkout. We will provide an update as soon as possible.
Posted Jul 14, 2025 - 11:54 PDT
This incident affected: Dashboard.