Slow Dashboard Interactions

Incident Report for Boulevard

Resolved

This incident has been resolved.
Posted Sep 24, 2026 - 12:53 PDT

Monitoring

We are seeing returns to normal levels for the dashboard response times. We are continuing to monitor.
Posted Sep 24, 2026 - 12:23 PDT

Investigating

We are investigating elevated dashboard load and interaction times.
Posted Sep 24, 2026 - 12:15 PDT
This incident affected: Dashboard.