Delayed Reports

Incident Report for Boulevard

Resolved

Data sync operations have been restored and completed. All reports are now showing current and accurate data. We apologize for any inconvenience this may have caused.
Posted Jan 22, 2026 - 16:16 PST

Investigating

We are currently investigating an issue causing delays in report data syncing. As a result, some reports may not display the most up-to-date data. We will provide further updates as more information becomes available.
Posted Jan 22, 2026 - 13:45 PST
This incident affected: Dashboard.