Payment Processing Disruption

Incident Report for Boulevard

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 13:12 PDT

Monitoring

The temporary outage our payment processing partner experienced has been resolved. Payments should now be processing as normal.
Posted Aug 26, 2026 - 13:09 PDT

Investigating

We are experiencing an issue with our payment processing partner and are currently investigating. During this time, a small subset of users may receive an error when processing a transaction for some clients.
Posted Aug 26, 2026 - 12:35 PDT
This incident affected: Dashboard, Duo App, Professional App, and Self-Booking Overlay.