This incident as been resolved. Boulevard will be conducting RCA and post mortem activities to prevent a future reoccurrence.
Posted Jan 20, 2026 - 16:34 PST
Update
We are continuing to monitor for any further issues.
Posted Jan 20, 2026 - 16:12 PST
Monitoring
We have successfully completed a system wide restart after increasing database capacity and a rolling restart. All services have been re-enabled. We continue to monitor performance and system stability as traffic returns to normal. Customers should be able to fully use Boulevard services at this time.
Posted Jan 20, 2026 - 14:34 PST
Update
You should begin to see performance improvements and online booking has been restored while we continue to investigate and monitor this situation and will post an update shortly.
Posted Jan 20, 2026 - 14:24 PST
Update
As we continue our work to correct this issue we are starting to restore services. Dashboard and duo checkouts are back up, but the self booking overlay is still under maintenance.
Posted Jan 20, 2026 - 14:15 PST
Update
Boulevard is restarting services across our infrastructure while we resolve the incident. During this process services will be unavailable.
Posted Jan 20, 2026 - 14:08 PST
Update
We are actively investigating the cause of the ongoing system delays affecting the platform. In the meantime, you may continue to experience slower response times and potential intermittent disruptions across all components. Our team is working diligently to resolve this as quickly as possible, and we appreciate your patience during this time. We'll provide another update as soon as possible.
As part of this investigation, we will be undergoing unscheduled online booking maintenance during this time. Please follow https://status.joinblvd.com for further updates.
Posted Jan 20, 2026 - 13:52 PST
Update
We are actively investigating the cause of the ongoing system delays affecting the platform. In the meantime, you may continue to experience slower response times and potential intermittent disruptions across all components. Our team is working diligently to resolve this as quickly as possible, and we appreciate your patience during this time. We'll provide another update as soon as possible.
Posted Jan 20, 2026 - 12:50 PST
Update
We are continuing to investigate the source of these delays and will post an update as soon as we have more information.
Posted Jan 20, 2026 - 12:28 PST
Update
We are continuing to investigate the source of these delays. During this time performance with the duo may also be impacted. We will update once we have additional information.
Posted Jan 20, 2026 - 11:38 PST
Investigating
We are currently investigating an issue with loading delays with the dashboard and will provide an update as soon as possible.
Posted Jan 20, 2026 - 09:49 PST
This incident affected: Dashboard, Duo App, Professional App, Self-Booking Overlay, and Client Portal.